Requirements

Server Requirements

  • Linux or Unix Server
  • Apache, Nginx or Lighttpd Web Server
  • MySQL or MariaDB >= 5.5 (5.7 MySQL or 10.0.5 MariaDB recommended)
  • PHP >= 5.6.33 (7.x recommended), CLI + mod_php or php-fpm or CGI/FastCGI
    • MySQLi Support
    • GD2 (with Freetype2) Support
    • CURL Support
    • SimpleXML Support
    • FTP Support
    • PCRE with UTF8/Unicode Properties
  • FFMpeg >= 2.8 (with support for libx264, webm and libfdk_aac)
  • FFProbe and QT-Faststart (both commands come with ffmpeg)
  • Image Magick convert and composite >= 6.93

Recommended PHP Configuration

  • safe_mode OFF
  • open_basedir OFF (or configured to allow ffmpeg/ffprobe/qt-faststart execution)
  • file_uploads ON
  • upload_max_filesize >= 100MB
  • post_max_size >= 100MBM
  • max_execution_time >= 7200
  • memory_limit >= 100MB
  • register_argc_argv ON
  • exec() function should be allowed

Options PHP Configuration and Extensions

  • OpCache Extension (improves script execution time, included by default in PHP >= 7.x)
  • Mbstring Extension (improves multi language and UTF8/Unicode rendering)
  • Memcache or Memcached Extension (with Memcached server running, used for caching)

Need help?

We can install the server requirements and make sure everything works as expected!
Order Now More Info

AdultScriptPro

Social Links